Skip to content

Downgrading ruby to 1.8.6 on Debian

I'm using Debian Lenny on my PowerBook. The ruby version which is shipped with lenny is 1.8.7.Today I wanted to try the metasploit framework, but it needs ruby version 1.8.6. After a little bit chatting in the channel a solution was found.

You have to add the following lines to your /etc/apt/source.list:
deb pool ruby1.8 deb-src pool ruby1.8

Now you can install the ruby packages from the snapshot mirrors. I installed the latest 1.8.6 version of ruby1.8 and libruby1.8
sudo aptitude install ruby1.8= libruby1.8=

To prevent aptitude of upgrading the packages you have to set them on hold:
sudo aptitude hold ruby1.8 libruby1.8