Skip to content

Downgrading ruby to 1.8.6 on Debian

I'm using Debian Lenny on my PowerBook. The ruby version which is shipped with lenny is 1.8.7.Today I wanted to try the metasploit framework, but it needs ruby version 1.8.6. After a little bit chatting in the channel a solution was found.

You have to add the following lines to your /etc/apt/source.list:
deb pool ruby1.8 deb-src pool ruby1.8

Now you can install the ruby packages from the snapshot mirrors. I installed the latest 1.8.6 version of ruby1.8 and libruby1.8
sudo aptitude install ruby1.8= libruby1.8=

To prevent aptitude of upgrading the packages you have to set them on hold:
sudo aptitude hold ruby1.8 libruby1.8


No Trackbacks


Display comments as Linear | Threaded

No comments

Add Comment

Enclosing asterisks marks text as bold (*word*), underscore are made via _word_.
Standard emoticons like :-) and ;-) are converted to images.
E-Mail addresses will not be displayed and will only be used for E-Mail notifications.

To prevent automated Bots from commentspamming, please enter the string you see in the image below in the appropriate input box. Your comment will only be submitted if the strings match. Please ensure that your browser supports and accepts cookies, or your comment cannot be verified correctly.

Form options